give it a name

in response to hughsie’s post about “refresh cache” in PackageKit (but not in the reponse comments as i don’t have or want a livejournal account) here’s some name suggestions:

Suspend: “Pause computer” (would be better when we can have those zero-power LCD displays)

Hibernate: “Switch off” (possibly this shouldn’t be available at all – it should just happen automatically if the battery’s getting low.  if there’s energy-usage issues about leaving systems paused then the hardware people should improve their suspend facilities.  or this happens automatically after an idle timeout.)

Power off: “Log out and switch off” (we shouldn’t need this anymore)

Reboot: “Log out and restart computer” “Apply system updates” (that’s the only time this should be needed – the option shouldn’t be available otherwise)

Refresh cache: “Update software list now”

i know they’re a bit wordy and the changes to ‘suspend’ and ‘hibernate’ rather depend on those functions (and their associated resume functions) really, really working properly! still,maybe it makes sense. annoyingly, it looks like, once again, Microsoft might have actually got a lot of this right in Vista.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s