t-mobile 3g stickage

old skool phone modem

old skool phone modem

i’m not t-mobile’s biggest fan by any means but i do like the idea of having a selection of 3G providers to choose from.

so i’ve ended up with this 3g usb stick from t-mobile which “works on windows and osx” – *sigh*

still, i’ve seen a few of these on vodafone and you just plug them in and NetworkManager does the rest, right?

well, almost.  if you’re still back on fedora 10 (what’ve you been doing all week?!) then you’ll need to do something (called ‘usbmodeswitch’) to switch the stick from ‘zerocd’ mode into 3g modem mode – in fedora 11 that’s done for you (by hal i think).  but then when you try to connect it fails.

googling around i found lots of people saying it doesn’t work if the settings have a blank username and password – doesn’t matter what they are as long as they’re not blank.  well i tried that but it made no difference.

tried calling t-mobile support who were moderately helpful and did say that i should try “user” and “pass” but that didn’t  help either.

they also said that there’s some other software you can download that sorts it all out for you.  more googling found ‘hsoconnect’ hosted on pharscape.org which was, at that time, blacklisted by google for apparently hosting viruses!  eek.

went to the t-mobile shop today and got the same story from them.  also they can’t swap the stick for a different model and they can’t accept it back from me either – i have to call support again.

so, thought i’d have another try at hsoconnect. pharscape.org is no longer blacklisted!  bit of a problem with the latest release because it’s python2.5-based but fedora 11 has 2.6.  then i found a beta version which runs on 2.6.  hoorah!

once i’d found that you have to create folders for it before you run the installer it finally ran … and failed.  reading some more comments it turns out that hsoconnect only ever works if you configure it yourself with username, password and APN.  APN?  ah ha!

tracked down the APN here … success!  then i thought, maybe that’s what the problem was all along …. and now i’m typing this using the 3g stick connected by NetworkManager! (well, i was, right up until t-mobile blocked me from finding a picture on flickr – even though the chap who sold it to me assured me he’d removed the block.  grrr.)

so, if you’ve got fedora 11 and a new uk t-mobile 3g stick you need to know:

go to the ‘connection settings’ in NetworkManager.

go to the mobile broadband connection and edit it.

set the username and password to anything non-blank.

set the APN to general.t-mobile.uk

success!  😀

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s